Excel: En önemli formüller | çevrimiçi

Elektronik tablolar, verileri düzenlemek ve analiz etmek için paha biçilmez bir araçtır. Excel, en popüler elektronik tablo uygulamalarından biridir ve alıştığınızda üretkenliğinizi önemli ölçüde artırabilir. Excel ile üretkenliğinizi en üst düzeye çıkarmak için, zaman alan hesaplamaları otomatikleştirmeye yönelik özellikleri kullanabilirsiniz. Excel’in, hızlı bir şekilde öğrenip e-tablonuzda kullanabileceğiniz basit işlevler de dahil olmak üzere çok sayıda yerleşik özelliği vardır. Bu on özellik, kısa sürede Excel’de uzmanlaşmanızı sağlayacaktır.

Reklamcılık

1. EĞER

Excel IF işlevi mantıksal bir ifade alır, ifadenin doğru olup olmadığını test eder ve ardından iki sonuç için özel çıktı döndürür.

=WENN(Prüfung;Dann_Wert;Sonst_Wert)

Testin mantıksal ifadesi 1>2 gibi basit bir ifade veya B2=1 gibi bir koşul olabilir. İfade doğruysa IF Then_value değerini döndürür. Aksi takdirde else_value değerini döndürür. IF, karmaşık formüller oluşturmada önemli bir işlevdir. Örneğin, birden çok koşul oluşturmak için birden çok IF işlevini iç içe kullanabilirsiniz.

Örnek: Aşağıdaki formül, B2’den B11’e toplamının 100’den büyük olup olmadığını kontrol etmek için IF’yi çağırır. Koşul karşılanırsa, IF “Evet” sonucunu döndürür. Aksi takdirde “Hayır” sonucunu döndürür.

=WENN(SUMME(B2:B11)>100;"Ja";"Nein")

2.TOPLA

ETOPLA, Excel’in en kullanışlı işlevlerinden biridir. Belirli kriterleri karşılayan değerleri özetler.

=SUMMEWENNS(Summenbereich;Kriterienbereich1;Kriterien1;...)

Excel’de ayrıca SUMIF adı verilen ve aynı işi yapan ancak yalnızca bir koşulu test edebilen, SUMIF ise birden fazla koşulu test edebilen bir işlev vardır. Yani SUMIF daha iyi bir fonksiyon olduğu için SUMIF’i esasen görmezden gelebilirsiniz. İşlev sizden toplanacak değer aralığını ve ardından kontrol edilecek her aralığı ve kontrol edilmesi gereken kriterleri sorar.

Örnek: Aşağıdaki formül, E3 hücresine girilen aralık için C sütunundaki değerleri toplar.

=SUMMEWENNS(C2:C11;B2:B11;E3)

3. COUNTİFLER

COUNTIFS, Excel’deki başka bir veri analizi işlevidir ve kriterleri birden çok aralıktaki hücrelere uygular ve her kriterin kaç kez uygulandığını sayar.

=ZÄHLENWENNS(Kriterienbereich1;Kriterien1;...)

ETOPLA işlevine çok benzer. COUNTIF işlevi, belirli kriterleri karşılayan değerlerin sayısını sayar. Bu nedenle SUMIF gibi bir toplam aralığına ihtiyaç duymaz. İşlevi Excel’de kullanmak için öncelikle saymak istediğiniz hücre aralığını girmeniz gerekir. Daha sonra sayılacak hücrelerin kriterlerini belirtmeniz gerekir.

Örnek: Aşağıdaki formül, E3 hücresine girilen cinsiyete sahip en az 10 yaşında olan kişilerin sayısını sayar.

=ZÄHLENWENNS(B2:B11;E3;C2:C11;">=10”)

4. ORTALAMA

ORTALAMA işlevi bir sayı grubunun ortalamasını hesaplar. Sayıları doğrudan girebilir veya bunları içeren hücrelere ve aralıklara başvurabilirsiniz.

=MITTELWERT(Wert1;Wert2;...)

ORTALAMA yalnızca sayılarla çalışır. Sayı ve metin içeren bir aralığa girdiğinizde metin hücreleri yok sayılır.

Örnek: Aşağıdaki formül C2’den C11’e kadar olan hücrelerin ortalama değerini döndürür.

=MITTELWERT(C2:C11)

5. MİN/MAKS

MIN ve MAX yalnızca tek bir amaca hizmet eden basit işlevlerdir: bir serideki en küçük veya en büyük değeri döndürürler. Yalnızca tek bir amaca hizmet etseler de birçok senaryoda faydalı olabilirler.

=MIN(Wert1;Wert2;...)

=MAX(Wert1;Wert2;...)

Hücrelere ve aralıklara başvurabilir veya değerleri doğrudan girebilirsiniz. MIN ve MAX yalnızca sayılarla çalışır ve metin içeren hücreleri yok sayar.

Örnek: Aşağıdaki formül C2’den C11’e kadar olan en küçük değeri döndürür.

=MIN(C2:C11)

Örnek: Aşağıdaki formül C2’den C11’e kadar olan en büyük değeri döndürür.

=MAX(C2:C11)

MIN ve MAX, bir aralıktaki en büyük ve en küçük değerler arasındaki farkı hesaplamak için de birleştirilebilir:

=MAX(C2:C11)-MIN(C2:C11)

6. ANAHTAR

Excel’in DEĞİŞTİRME işlevi, hücrelerde belirli bir dizeyi aramanıza ve onu başka bir dizeyle değiştirmenize olanak tanır.

=WECHSELN(Text;Alter_Text;Neuer_Text;ntes_Auftreten)

Bu sözdiziminde metin hedef hücredir, eski_metin değiştirilecek parçadır ve yeni_metin değiştirilecek parçadır. Son argüman olan nth_occurrences isteğe bağlıdır. Ntes_occurrences’ı boş bırakırsanız, CHANGE, eski_metnin tüm örneklerini yeni_metinle değiştirecektir. N’inci_oluş için 2 girerseniz, CHANGE, eski_metin’in ikinci örneğini yeni_metinle değiştirir. Bu formül hem sayı hem de metin dizeleriyle çalışır.

Örnek: Aşağıdaki formül, B2 hücresindeki + ifadesini “ve” ile değiştirir. Son argüman boş bırakıldığı için tüm örnekler değiştirilir.

=WECHSELN(B2;"+";"und")

7. ZİNCİR

CONCATENATE işlevi, birden fazla hücredeki değerleri tek bir hücrede birleştirir.

=VERKETTEN(Text1;Text2;…)

Bu, bir kişinin adı, adresi, referans numarası, dosya yolu veya URL gibi farklı metin parçalarını birleştirmek için kullanışlıdır.

Örnek: Aşağıdaki formül, adı ve soyadını tam ad olarak birleştirir. Text2 argümanı için bir boşluk girilir.

=VERKETTEN(A2;" ";B2)

8. SOL/SAĞ

LEFT ve RIGHT işlevleri CONCATENATE’in tersini yapar. Bir metnin başından ve sonundan belirli sayıda karakter çıkarırlar.

=LINKS(Text;Anzahl)

=RECHTS(Text;Anzahl)

Bu formül, daha fazla analiz için bir adresin, bir URL’nin veya bir referansın bölümlerini çıkarmak için kullanılabilir. SOL ve SAĞ işlevleri aynı bilgileri sorgular. Metnin nerede olduğunu ve kaç karakter çıkarmak istediğinizi bilmek istiyorsunuz.

Örnek: A Sütunu, SOL kullanılarak ilk iki harfe kısaltılmış günleri içerir.

=LINKS(A2;2)

9. DÜŞEYARA

DÜŞEYARA işlevi Excel’de en çok kullanılan ve en iyi bilinen işlevlerden biridir. Bir tabloda bir değer arar ve bu değerle ilgili başka bir sütundan bilgi döndürür.

=SVERWEIS(Suchkriterium;Bereich;Spaltenindex;Wahrheitswert)

Formül, farklı listelerdeki verileri tek bir listede birleştirmek veya iki listeyi eşleşen veya eksik öğeler açısından karşılaştırmak için kullanışlıdır. Excel veri analizinde önemli bir araçtır. Dört bilgi ister: aramak istediğiniz değer, hangi tabloda arama yapacağınız, döndürmek istediğiniz bilgiyi hangi sütunda içerdiği ve gerçekleştirmek istediğiniz arama türü.

Örnek: İnsanların yaşlarının olduğu bir tablo var. Bu kişiler hakkında daha fazla bilgi içeren başka bir tablo daha var (kolaylık olması açısından, tablo hemen yanındadır, ancak bunu başka bir e-tabloda da hayal edebilirsiniz). İnsanların hangi renkleri seçtiğini gösteren veriler DÜŞEYARA kullanılarak yaş tablosuna dahil edilmelidir.

=SVERWEIS(A2;G2:H11;2;FALSCH)

DÜŞEYARA hakkında daha fazla bilgiyi bu makalede bulabilirsiniz.

10. DEĞER

Çoğu zaman analiz etmeniz gereken veriler bir yerden kopyalanıp yapıştırılır. Bu genellikle verilerin yanlış formatta olmasına neden olur; örneğin bir sayı metin olarak kaydedilmişse. Hücrede sola hizalanmışlarsa sayıların metin olarak kaydedildiğini anlayabilirsiniz. Değer olarak sayılar hücrelerde sağa hizalanmıştır. Daha sonra, Excel bunu sayı olarak tanımazsa, SUM gibi veri analizi görevlerini gerçekleştiremezsiniz.

Neyse ki bu konuda size yardımcı olacak VALUE işlevi var. Görevi, metin olarak saklanan sayıları sayısal değerlere dönüştürmektir.

=WERT(Text)

İşlev sizden dönüştürülecek metni girmenizi isteyecektir.

Örnek: Aşağıdaki formül, B sütununda metin olarak saklanan yaşları sayıya dönüştürür.

=WERT(B2)


(işba)

Haberin Sonu

Elektronik tablolar, verileri düzenlemek ve analiz etmek için paha biçilmez bir araçtır. Excel, en popüler elektronik tablo uygulamalarından biridir ve alıştığınızda üretkenliğinizi önemli ölçüde artırabilir. Excel ile üretkenliğinizi en üst düzeye çıkarmak için, zaman alan hesaplamaları otomatikleştirmeye yönelik özellikleri kullanabilirsiniz. Excel’in, hızlı bir şekilde öğrenip e-tablonuzda kullanabileceğiniz basit işlevler de dahil olmak üzere çok sayıda…

Bir yanıt yazın

E-posta adresiniz yayınlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir